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1. Installation

1.1 Select Columns UI Open foobar2000 and choose Columns UI as your User 
Interface Module.

 If you haven't used Columns UI before you will be 
asked on startup which Display to use.

Choose Columns UI and in the following window choose 
one of the Presets (it will be overwritten after importing 
the DarkOne configuration file).

 If you have already installed Columns UI in your 
components folder but haven't used it so far, please go to 
File → Preferences → Display and choose Columns UI as 
your User Interface Module.

In this case you will have to restart foobar2000 to take 
effect.

Öffnen Sie foobar2000 und wählen Sie Columns UI als 
Ihr User Interface Module.

 Sollten Sie bislang noch kein Nutzer von Columns UI 
gewesen sein, werden Sie durch einen Dialog gefragt, 
welche Benutzeroberfläche Sie benutzen möchten.

Wählen Sie hier Columns UI aus und im nachfolgenden 
Dialog irgendein Preset (dieses wird durch den 
anschließenden Import der DarkOne Konfigurationsdatei 
überschrieben).

 Sollte sich bereits Columns UI bislang ungenutzt in 
Ihrem user-components Verzeichnis befinden, gehen Sie 
bitte über File → Preferences → Display und wählen 
Columns UI als Ihr User Interface Module.

In diesem Fall müssen Sie foobar2000 neu starten.
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1.2 Import the configuration file Import the file DarkOne v3.0.fcl from the folder 
...\foobar2000\themes\DarkOne via File → Preferences → 
Display → Columns UI → Main tab → FCL importing and 
exporting → Import.

Importieren Sie bitte die Datei DarkOne v3.0.fcl aus dem 
...\foobar2000\themes\DarkOne-Ordner über File → 
Preferences → Columns UI → Registerkarte Main → FCL 
importing and exporting → Schaltfläche Import.
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1.3 Reset Global Variables To avoid possible incompatibilities with a previous 
configuration, please do a right-mouse-click as illustrated, 
choose Global Variables tab and hit the button Delete All 
to reset the global variables.

Um mögliche Inkompatibilitäten mit einer früheren 
Konfiguration zu vermeiden, klicken Sie bitte mit der 
rechten Maustaste wie abgebildet, wählen Sie die 
Registerkarte Global Variables → Schaltfläche Delete All, 
um die globalen Variablen zurückzusetzen.
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1.4 Disabling Frame Styles It may happen that you have to set the Frame style to 
None for some panels. Then please do the following:

Bei einigen Panels muss u. U. Der Frame Style auf None 
gesetzt werden. Dann bitte wie folgt vorgehen:

❶ Album List Panel

MENU → File → Preferences → Media Library → Album list 
panel → Advanced tab → Window frame style

❶ Album List Panel

MENU → File → Preferences → Media Library → Album list 
panel → Registerkarte Advanced → Window frame style

❷ Filter

MENU → File → Preferences → Columns UI → Filter tab → 
Edge style

❷ Filter

MENU → File → Preferences → Columns UI → 
Registerkarte Filter → Edge style

❸ Item Details Panel

1.) Right-click on the Trackinfo-Panel (centre on the left) 
→ Options → Panel edge style

2.) Right-click on the buttons on the lower right side → 
Splitter Settings → PanelList tab → select DET → hit 
Configure button → Panel edge style

❸ Item Details Panel

1.) Rechtsklick auf das Trackinfo-Panel (links, mittig über 
dem Display) → Options → Panel edge style

2.) Rechtsklick auf die Schaltflächen unten rechts → 
Splitter Settings → Registerkarte PanelList → DET 
auswählen → Schaltfläche Configure betätigen → Panel 
edge style

❹ Item Properties

Right-click on the buttons on the lower right side → 
Splitter Settings → PanelList tab→ select INF → hit 
Configure button → Panel edge style

❹ Item Properties

Rechtsklick auf die Schaltflächen unten rechts → Splitter 
Settings → Registerkarte PanelList → INF auswählen → 
Schaltfläche Configure betätigen → Panel edge style

❺ NG Playlist

Preferences → Columns UI → Playlist view → General 
tab→ Playlist edge style

❺ NG Playlist

MENU → File → Preferences → Columns UI → Playlist 
view → Registerkarte General → Playlist edge style
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1.5 Background picture An image can be displayed in the background of the 
default Playlist view (ELPlaylist and also the MiniPlaylist, 
see chapters 2.8.1 and 2.8.3). By default DarkOne is set 
up to display an image that is called artist.* (* means: 
“Wildcard”, not necessary to specify the file extension) 
and is present in the musics folder. If you want to change 
the path you have to do this manually by a click as 
illustrated on the left.

Im Hintergrund der Standard-Wiedergabelistenansicht 
(ELPlaylist und MiniPlaylist, siehe Kapitel 2.8.1 und 2.8.3) 
kann ein Bild angezeigt werden. In der Grundeinstellung 
der Konfiguration wird hier ein Bild angezeigt, welches 
artist.* (* bedeutet: „Wildcard“, eine Dateiendung ist nicht 
erforderlich) heißt und sich im Ordner mit den 
Musikdateien befindet. Den Pfad können Sie natürlich 
Ihren Bedürfnissen durch einen wie links abgebildeten 
Klick anpassen, um auch Bilder anzuzeigen, die an 
einem anderen Speicherort vorliegen.

Select Script → PerTrack and change the blue framed 
Script part illustrated on the left to your desired Path and 
Naming format. Title Formatting skills may be necessary. 
Wildcards for file extensions or file names, e. g. artist*.* 
instead of artist_01.jpg, are possible.

In addition you may want to change the transparency of 
the background image by changing the alpha-value in the 
red framed Script part (by default 32) to your desired 
value (between 0 and 255).

Wählen Sie dazu Script → PerTrack und ändern Sie den 
in der nebenstehenden Abbildung blau umrandeten 
Script-Teil auf den gewünschten Pfad und das 
bevorzugte Namensformat. Hierbei sind Title Formatting 
Kenntnisse u. U. empfehlenswert. Wildcards für 
Dateiendungen und Namenszusätze, z. B. artist*.* statt 
artist_01.jpg, sind möglich.

Zusätzlich können Sie noch die Transparenz des 
Hintergrundbildes ändern, indem Sie die Zahl 
(standardmäßig 32) im rot umrandeten Script-Teil auf den 
gewünschten Alpha-Wert (zwischen 0 und 255) ändern.
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1.6 Quicksearch Toolbar Bitmap To fit the appearance of the search symbol of the 
Quicksearch toolbar to the appearance of DarkOne 
please click once on the current search symbol and 
select Options → Custom bitmap.

Select the file QS.bmp from the folder 
...\foobar2000\themes\DarkOne\Images .

Um auch der Quicksearch Toolbar ein passendes 
„Suchsymbol“ zu verpassen, klicken Sie auf dessen 
aktuelles Suchsymbol und wählen Sie → Options → 
Custom bitmap.

Wählen Sie die Datei. QS.bmp aus dem Ordner 
...\foobar2000\themes\DarkOne\Images.
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2. Usage

2.1 Control Panel These buttons should be self-explanatory.

The buttons position will be rearranged depending on 
your display resolution (as illustrated on the left).

The LAST.FM button as seen on the screenshot only 
appears if the optional Plugin foo_lastfm_radio.dll is 
installed.

Otherwise there's a CLEAR LIST button on resolutions 
smaller than 1600*x and an ADD LOC. button (to add an 
URL to the Playlist) on higher resolutions.

Die Schaltflächen sollten selbsterklärend sein.

Je nach Auflösung des Displays ordnen sich die 
Schaltflächen neu an (wie nebenstehend abgebildet).

Die in den Abbildungen sichtbare LAST.FM Schaltfläche 
steht Ihnen nur zur Verfügung, wenn die optionale 
foo_lastfm_radio.dll installiert ist.

Andernfalls steht bei Display-Auflösungen kleiner als 
1600*x die Schaltfläche CLEAR LIST und bei größeren 
Auflösungen die Schaltfläche ADD LOC. (um eine URL in 
die Wiedergabeliste hinzuzufügen) zur Verfügung.
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2.2 Rating Panel According to the chosen mode the stars in the rating 
panel will display Ratings (white), Playcounts (green) or 
an automatic rating (blue) generated by informations from 
the now playing track.

The needed function is selectable during playback 
through a context menu by doing a right mouse click on 
the stars:

In STOP-state the “normal” context menu of the panel 
(Properties and Configure only) is displayed instead.

Die Sterne im Bewertungs-Panel zeigen je nach 
gewähltem Modus entweder die manuelle Bewertung 
(weiß), die Abspielanzahl (grün) oder eine aus 
vorhandenen Daten des spielenden Liedes ermittelte 
automatische Bewertung (blau) an.

Die gewünschte Funktion lässt sich während eines 
Abspielvorganges über das mit Rechtsklick auf die Sterne 
zu öffnende Kontextmenü auswählen.

Im STOPP-Zustand ist nur das normale Kontextmenü des 
Panels (Properties und Configure) verfügbar.

2.2.1 Rating options ❶ Delete rating

Deletes existing rating informations (only active if rating 
information is present in the file).

❷ Show/enable rating

Displays rating informations in white stars and enables 
the functionality to rate the now playing song by clicking 
on the desired amount of stars.

❸ Show auto-rating 

Displays the automatic rating in blue stars.

This rating generates itself by the amount of play counts 
and the days a file has been left in the database since it 
was first played. It doesn't change the files or their 
database entries itself, but is only and exclusively 

❶ Delete rating

Löscht vorhandene Bewertungen (nur funktionsfähig, 
wenn eine Bewertung vorliegt).

❷ Show/enable rating

Zeigt vorhandene Bewertungen in weißen Sternen an. 
Bewertet werden kann durch einen Klick auf die 
gewünschte Anzahl an Sternen.

❸ Show auto-rating 

Zeigt die automatische Bewertung eines Liedes in blauen 
Sternen an. Diese Bewertung ermittelt sich aus der 
Anzahl der Abspielvorgänge und der Dauer seit dem 
ersten Abspielvorgang, verändert jedoch weder die 
Dateien noch deren Datenbankeinträge, sondern wird 
lediglich von DarkOne exklusiv für diese Bewertungs-
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generated by DarkOne for this rating display.
The manual rating functionality is disabled in this mode.

❹ Show playcounts

Displays the play counts of the now playing track in green 
stars.
The manual rating functionality is disabled in this mode.

❺ Rate to the database

If Show/enable rating is selected, ratings will be stored to 
the database.
You may recognise the enabled database rating mode on 
the yellow “mousehover” stars.
In this mode ratings in the database will be signalised by 
the stars in prior to ratings in the Metadata (TAGS) if 
they're both present for the file!
If you rate a song in this mode ratings in the Metadata 
(TAGS) that are eventually present will be deleted to 
avoid a doubled rating!

❻ Rate to the file tags

If Show/enable rating is selected, ratings will be stored to 
the file tags.
You may recognise the enabled tag rating mode on the 
white outlined “mousehover” stars.
In this mode ratings in the Metadata (TAGS) will be 
signalised by the stars in prior to ratings in the database if 

Anzeige generiert! 
Die manuelle Bewertungsmöglichkeit ist in diesem Modus 
deaktiviert!

❹ Show playcounts

Zeigt die Abspielvorgänge des spielenden Liedes in 
grünen Sternen an.
Die manuelle Bewertungsmöglichkeit ist in diesem Modus 
deaktiviert!

❺ Rate to the database

Ist Show/enable rating aktiviert, werden Bewertungen in 
die Datenbank geschrieben und durch gelbe 
„Mousehover“-Sterne signalisiert.
In diesem Modus werden bei gleichzeitigem Vorliegen 
von Bewertungen in der Datenbank und den Metadaten 
(TAGS) die Bewertungen in der Datenbank bevorzugt 
angezeigt.
Wird eine Bewertung in diesem Modus gesetzt, werden 
evtl. vorliegende Bewertungen in den Metadaten (TAGS) 
gelöscht, um eine Doppelbewertung zu vermeiden!

❻ Rate to the file tags

Ist Show/enable rating aktiviert, werden Bewertungen 
hiermit in die Dateien (Tags) geschrieben.
An der weißen Farbe der „Mousehover“-Sterne kann man 
erkennen, dass diese Bewertungsmöglichkeit gewählt ist. 
In diesem Modus werden bei gleichzeitigem Vorliegen 
von Bewertungen in der Datenbank und den Metadaten 
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they're both present for the file!
If you rate a song in this mode ratings in the database 
that are eventually present will be deleted to avoid a 
doubled rating!

❼ Playcount limit

If Show playcounts is selected, you can set up the 
amount of play counts a song has to be left before 
displaying all stars.

❽ Properties

Calls the Properties-Window of the panel.
If you don't want to use the context menu, you can 
change the Display Mode (0 for Show/enable rating, 1 for 
Show auto-rating or 2 for Show playcounts), the Rating 
Mode (0 for Rate to database or 1 for Rate to file tags) 
and the Playcounter limit (as number from 0-x) here.
In addition you can change the background colour 
independently from the global colour scheme. Read more 
about this in chapter 3.

❾ Configure 

Shows the script of the panel.

It is strongly disrecommended to change anything in this 
script without any knowledge about the script language 
(JavaScript)!

(Tags) die Bewertungen in den Metadaten (Tags) 
bevorzugt angezeigt.
Wird eine Bewertung in diesem Modus gesetzt, werden 
evtl. vorliegende Bewertungen in der Dastenbank 
gelöscht, um eine Doppelbewertung zu vermeiden!

❼ Playcount limit

Ist Show playcounts aktiviert, kann hiermit festgelegt 
werden, bei welcher Anzahl an Abspielvorgängen alle 
fünf Sterne aufleuchten sollen.

❽ Properties

Zeigt das Eigenschaften-Fenster des Panels an. Hierin 
kann ebenfalls der Display Mode (0 für Show/enable 
rating, 1 für Show auto-rating oder 2 für Show 
playcounts), der Rating Mode (0 für Rate to database 
oder 1 für Rate to file tags) und das Playcounter limit (als 
Zahlenwert von 0-x) angegeben werden.
Außerdem ist es möglich, die Hintergrundfarbe des 
Panels unabhängig vom globalen Farbschema abzuän-
dern, Lesen Sie mehr dazu in Kapitel 3.

❾ Configure 

Zeigt das Skript des Panels an.

Es wird dringend abgeraten, ohne Vorkenntnisse in der 
Sprache des Skripts (JavaScript) Änderungen darin 
vorzunehmen!
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2.3 Trackinfo Panel The area where informations about the now playing track 
are displayed is a Columns UI Item details panel.

You can change the informations that are displayed in the 
panel with Options, available by doing a right mouse click 
on it (Title Formatting skills are necessary for this 
purpose).

You can also change the behaviour of the panel with a 
right mouse button click. By default it is set up to display 
informations about the now playing track.

But in Displayed track you can also choose to display 
information of a selected track or select an automatic 
mode instead.

Bei dem Bereich, in dem die Informationen des Liedes 
angezeigt werden, handelt es sich um ein Columns UI 
Item details panel.

Durch Rechtsklick auf das Panel gelangt man in dessen 
Options, in denen man die angezeigten Informationen 
festlegen kann (hierzu werden Title Formatting 
Kenntnisse benötigt).

Ebenfalls über Rechtsklick kann man das Verhalten des 
Panels ändern. So ist es standardmäßig eingestellt, nur 
Informationen über das gerade spielende Lied 
wiederzugeben.

Das Panel kann über Displayed track jedoch auch auf ein 
in der Wiedergabeliste ausgewähltes Lied oder auf eine 
Automatik umgestellt werden.
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2.4 Display and Seekbar
 ❶ ❷

The Display and the Seekbar has two different views that 
– depending on the active view - can be switched with the 
buttons illustrated on the left:

❶ Classical Display

❷ Waveform seekbar Display

Das Display und die Seekbar hat zwei Ansichten, die sich 
je nach gerade aktiver Ansicht mit nebenstehenden 
Buttons schalten umschalten lassen:

❶ Classical Display

❷ Waveform seekbar Display

2.4.1 Classical Display The progress bar (at the top) is also a seekbar in which 
you can drag with the left mouse button or the mouse 
wheel to every point in the playing file.

The “seek time” will be displayed in the display below.

Since there is no seeking possible in Streams the 
seekbar function is deactivated by listening to them.

There are further informations displayed in the display – 
as long as they are available.
 LOSSY/LOSSLESS – shows if the playing file is 
encoded lossy or lossless.
 AUDIO MD5 – lights up when the playing file has a 
MD5 checksum.
 REPLAYGAIN – light up when the playing file has 
Replaygain info.

The Elapsed-/Remain-Time and Bitrate will be replaced 
by the volume value on volume changes for about three 
seconds.

Der Fortschrittsbalken (oben) dient gleichzeitig als 
Suchleiste, in der man mit gedrückter linker Maustaste 
oder dem Mausrad eine bestimmte Stelle im gerade 
spielenden Lied suchen kann.

Die „Suchzeit“ wird unten im Display angezeigt.

Da bei Streams kein Suchen möglich ist, ist diese 
Funktion hierbei jedoch abgeschaltet.

Im Display werden – soweit verfügbar - weitere 
Informationen zum gerade spielenden Lied angezeigt:
 LOSSY/LOSSLESS – zeigt an, ob das Lied 
verlustbehaftet oder verlustfrei komprimiert wurde.
 AUDIO MD5 – leuchtet auf, wenn das Lied eine MD5-
Prüfsumme hat.
 REPLAYGAIN – leuchtet auf, wenn das Lied eine 
Replaygain-Info hat.

Bei Änderung der Lautstärke wird diese für drei 
Sekunden an Stelle der Spiel-/Restzeit und der Bitrate 
eingeblendet.
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2.4.2 Waveform seekbar Display The Waveform seekbar (at the top) is also a seekbar in 
which you can drag with the left mouse button to every 
point in the playing file.

The “seek time” will be displayed as a Tooltip.

Since there is no seeking possible in Streams the 
Waveform seekbar is completely deactivated by listening 
to them.

The playback time will be displayed right hand below the 
Waveform seekbar. It can be switched to display the 
remaining time by a left mouse click.

Die Waveform seekbar (oben) dient neben der Anzeige 
der Wellenstruktur eines Liedes gleichzeitig als 
Suchleiste, in der man mit gedrückter linker Maustaste 
eine bestimmte Stelle im gerade spielenden Lied suchen 
kann.

Die „Suchzeit“ wird dabei als Tooltip angezeigt.

Da bei Streams kein Suchen möglich ist, ist die 
Waveform seekbar hierbei jedoch komplett deaktiviert.

Rechts unterhalb der Waveform seekbar wird die aktuelle 
Spielzeit, durch einen Mausklick auf diese die 
Restspielzeit angezeigt.

2.4.3 Peakmeter There's a Peakmeter below the information 
unit/Waveform seekbar, which appearance can be fit to 
your needs.

To do so do a right mouse click on it and choose Splitter 
Settings. On the Panel List select the Peakmeter and hit 
Configure.

Changing the appearance may be necessary when you  
change the global colour scheme of DarkOne (see  
chapter 3) since the Peakmeters background colour  
doesn't adopts the settings made in Columns UI  
automatically.

Unterhalb des Informationseinheit/Waveform seekbar 
befindet sich ein Peakmeter, das in seiner Erscheinung 
ganz nach Belieben angepasst werden kann.

Hierzu mit der rechten Maustaste darauf klicken und 
Splitter Settings wählen. In der Panel List den Peakmeter 
auswählen und die Schaltfläche Configure betätigen.

Eine Änderung des Erscheinungsbildes kann nötig  
werden, wenn Sie das gesamte Farbschema von  
DarkOne ändern möchten (siehe Kapitel 3), da die  
Hintergrundfarbe des Peakmeters sich nicht automatisch  
mit den Einstellungen von Columns UI verändert.
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The according settings are db Range (in the upper left 
corner of the Preferences window) and the Colors button 
(downright of the window).

If you have changed its settings and you're not satisfied 
with the result you can go back to configurations default 
setting by choosing the PEAKdefault.pmf from the
...\foobar2000\themes\DarkOne\Others\Settings folder 
with the Import Settings option in its context menu.

Im Preferences-Fenster sind zur Farbänderung die db 
Range (links oben) und die Schaltfläche Colors (rechts 
unten) von Belang.

Sollten Sie mit dem Ergebnis Ihrer Bemühungen nicht 
zufrieden sein, können Sie jederzeit den 
„Auslieferungszustand“ über die Rechtsklick-Option 
Import Settings und Auswahl der Datei PEAKdefault.pmf 
aus dem Ordner 
...\foobar2000\themes\DarkOne\Others\Settings 
wiederherstellen.
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2.5 Cover Panel If available through the foobar2000 artreader (see 
chapter 2.5.1) or the panel configuration Custom Pictures 
(see chapter 2.5.2) album arts from the now playing file 
will be displayed in the Cover Panel on the down left side 
of the configuration.

If there's no image available an alternative DarkOne 
image will be displayed instead.

In der Coveranzeige am linken unteren Rand der 
Konfiguration wird – soweit über den foobar2000 
Artreader (siehe Kapitel 2.5.1) oder über die 
Panelkonfiguration Custom Pictures (siehe Kapitel 2.5.2) 
verfügbar – das Cover des aktuell spielenden Liedes 
angezeigt.

Ist kein Bild verfügbar wird für jeden Bildtyp ein eigenes 
DarkOne-Ersatzbild angezeigt.

2.5.1 foobar2000 artreader Album art embedded to the file tags will be recognized 
automatically by the foobar2000 artreader.

To display external artwork too you have to add/change 
paths and naming patterns, when yours are different than 
the preconfigured paths and naming patterns.

Please click on the MENU button (on the left above the 
Playlist views) and choose File → Preferences → Display.

Here is the place to add your naming schemes and/or 
paths for up to four images (Front cover, Back cover, 
Artist (for an artist picture) and Disc) you may want to 
display in the cover panel and – at least the Front cover 
and the Artist – in the Playlist views.

Title-Formatting and Wildcards are possible.

In addition you can set up paths to Stub images for each 
tab to display when there's no match in the Search 

In den Tags befindliche Bilder (embedded album art) 
werden vom foobar2000 artreader standardmäßig 
erkannt.

Um externe Bilder über den artreader anzeigen zu 
lassen, ist es natürlich notwendig, Pfade und/oder 
Namensschemen zu diesen Bildern anzugeben, wenn 
diese von den voreingestellten Pfaden und/oder 
Namensschemen abweichen.

Gehen Sie dazu über die Schaltfläche MENU (ganz links 
oberhalb der Wiedergabelistenansicht) zu File → 
Preferences → Display.

Hier können Sie nun für vier Bildarten (Front cover, Back 
cover, Artist (für ein Interpretenbild) und Disc) Pfade 
und/oder Namensschemen angeben, um diese Bilder 
über die Coveranzeige, sowie das Front cover in den 
Wiedergabelistenansichten, in Dark-One anzeigen zu 

16

http://wiki.hydrogenaudio.org/index.php?title=Foobar2000:Titleformat_Reference


pattern and you're not satisfied with the default DarkOne 
stub images. These stub images will be displayed in the 
Playlist views too (see chapters 2.8).

At least it is recommended to set up a stub image for the 
Front cover when you have activated Display artwork in 
groups in NG Playlist (see chapter 2.8.2) or of course for 
the EsPlaylist („Graphical browser“, see chapter 2.10.1.3) 
since these Playlist views can't be preconfigured to use 
the DarkOne default stub images.

If you want to use the DarkOne default NoCover-Image, 
that is already used by the configuration except by the 
NG Playlist and the EsPlaylist, you'll find it in the 
...\foobar2000\themes\DarkOne\Images folder.

lassen. Title-Formatting und Wildcards sind hierbei 
möglich.

Zusätzlich können Sie auch Ersatzbilder (sogenannte 
Stub images) für jeden der vier über den artreader 
möglichen Bildarten angeben, wenn Ihnen die DarkOne-
Standard-Ersatzbilder, die in der Coveranzeige 
voreingestellt sind, nicht zusagen. Diese Ersatzbilder 
werden dann ebenfalls von den 
Wiedergabelistenansichten (siehe Kapitel 2.8) 
übernommen.

Es empfiehlt sich zumindest für das Front cover hier ein 
Ersatzbild anzugeben, wenn Sie in der NG Playlist (siehe 
Kapitel 2.8.2) Display artwork in groups aktivieren und 
natürlich für die EsPlaylist („Graphical browser“, siehe 
Kapitel 2.10.1.3), da diese Wiedergabelistenansichten 
nicht für die DarkOne-Standard-Ersatzbilder 
vorkonfigurierbar sind.

Möchten Sie hierzu das DarkOne-Standard-NoCover-
Image verwenden, welches ohnehin in der gesamten 
Konfiguration mit Ausnahme der NG Playlist und der 
EsPlaylist genutzt wird, finden Sie dieses im Ordner
...\foobar2000\themes\DarkOne\Images.

17

http://wiki.hydrogenaudio.org/index.php?title=Foobar2000:Titleformat_Reference


2.5.2 Custom Pictures In addition to the images provided by the foobar2000 
artreader you can also display custom images in the 
cover Panel.

Please click with the right mouse button on the cover 
Panel and choose Properties.

Double-click on one of the lines in the blue framed area 
as illustrated on the left and type in your path and naming 
scheme of the desired picture. Wildcards, relative paths 
and Title-Formatting are possible. So you can display up 
to five different custom images in the cover Panel.

If there is more than one image that fits this pattern you 
can force a priority for preferred file extensions as 
illustrated in the red framed box.

Like preconfigured you need to separate the file 
extensions with a |.

Click OK to apply your action.

Zusätzlich zu den Bildern, die der foobar2000 Artreader 
zur Verfügung stellt, können Sie in der Coveranzeige 
auch benutzerdefinierte Bilder anzeigen lassen.

Klicken Sie dazu mit der rechten Maustaste auf die 
Coveranzeige und wählen Sie Properties.

Im in der nebenstehenden Abb. blau umrandeten Bereich 
können Sie per Doppelklick auf die jeweilige Zeile den 
Pfad mit Namensschema zum gewünschten Bild 
angeben. Wildcards, relative Pfade und Title-Formatting 
werden hierbei unterstützt. So können Sie bis zu fünf 
verschiedene Bilder anzeigen lassen. Sollten mehrere 
Bilder mit gleichem Namensschema, aber 
unterschiedlicher Dateiendung, unter dem gleichen Pfad 
vorliegen, können Sie im in der Abb. rot umrandeten 
Bereich festlegen, in welcher Reihenfolge die 
Dateiendungen hierbei abgefragt werden sollen und 
damit eine absteigende Priorität der Dateiendungen 
bestimmen.

Wie vorgegeben, sind diese Dateiendungen jeweils durch 
ein | zu trennen.

Mit einem Klick auf die Schaltfläche OK bestätigen Sie 
Ihre Einträge.
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2.5.3 Mouse actions All mouse actions are only active during playback (except 
the default WSH Panel mod context menu)!

Mit Ausnahme des Standard-Kontextmenüs des WSH 
Panel mod sind sämtliche Maus-Funktionen nur während 
eines Abspielvorganges aktiv!

2.5.3.1 Left mouse button Switches only between existing images in Album Art or 
Custom Pictures mode. If you have set up Stub images in 
the foobar2000 artreader they will be switched too!

Schaltet zwischen vorhandenen Bildern des Artreaders 
bzw. zwischen vorhandenen benutzerdefinierten Bildern 
um. Sollten im Artreader Stub images angegeben worden 
sein, werden auch diese Bilder beim Umschalten 
berücksichtigt!

2.5.3.2 Middle mouse button Switches between foobar2000 artreader and Custom 
Pictures mode and jumps to the first image of each mode 
(Front cover or Picture 1 depending on mode). If there's 
no image available here, the Cover Panel automatically 
jumps to the first existing image.

Schaltet zwischen dem foobar2000 artreader und dem 
benutzerdefinierten Modus um, wobei jeweils das erste 
Bild (Front Cover bzw. Picture 1) angezeigt wird. Sollte 
dieser Bildplatz unbelegt sein, springt die Coveranzeige 
automatisch  zum ersten vorhandenen Bild.

2.5.3.3 Right mouse button Activates the context menu with the following entries 
(only duing PLAYBACK):

❶ Resize Options

➢ Keep aspect ratio 
resizes the image to the max. Panel size but 
respects its aspect ratio

➢ Noexpansion 
also keeps the aspect ratio but doesn't enlarges 
the image when the Panel size is greater than the 
images dimensions

Aktiviert das Kontextmenü des Cover Panels mit 
folgenden Einträgen (nur während PLAY):

❶ Resize Optionen

➢ Keep aspect ratio  
verändert die Größe das anzuzeigenden Bildes auf 
die maximale Panelgröße, behält dabei aber das 
Seitenverhältnis bei.

➢ Noexpansion
behält das Seitenverhältnis bei, vergrößert das 
anzuzeigende Bild aber nicht, wenn die Panel-
größe die Dimensionen des Bildes übersteigt.

19



➢ Stretch 
resizes the image to the max. Panel size without 
respecting its aspect ratio

❷ Modes (depends on active mode)

➢ Album Art 
activates displaying images provided by the 
foobar2000 artreader (see chapter 2.5.1)

➢ Custom Pictures 
activates displaying the Custom Pictures as set up 
in the Panel Properties (see chapter 2.5.2)

➌ Front Cover/Picture 1, Back Cover/Picture 2, 

Disc/Picture 3, Icon/Picture 4, Artist/Picture 5
selects the according image directly (entries are changing 
their names depending on the active mode)

➍ Auto Cycle Image

changes Images after a predefined interval (see 
Properties). Deactivates the manual selection.

➎ Faded Transition

(only active when Auto Cycle Image is chosen)
enables a fading effect during auto cycling.

WARNING:
This Faded Transition may not work correctly with 
Windows XP/Vista. It is recommended for the use on 
Windows 7 only!

➢ Stretch 
dehnt das anzuzeigende Bild auf die maximale 
Panelgröße ohne Rücksicht auf das Seitenver-
hältnis.

❷ Modi (Anzeige je nach aktivem Modus)

➢ Album Art 
aktiviert die Anzeige der Bilder, die der foobar2000 
artreader zur Verfügung stellt (siehe Kapitel 2.5.1)

➢ Custom Pictures 
aktiviert die Anzeige der benutzerdefinierten 
Bilder, die über die Panel Properties angelegt 
werden (siehe Kapitel 2.5.2)

➌ Front Cover/Picture 1, Back Cover/Picture 2, 

Disc/Picture 3, Icon/Picture 4, Artist/Picture 5
direkte Anwahl des gewünschten Bildes (die Benennung 
hängt vom gewählten Modus ab)

➍ Auto Cycle Image

wechselt automatisch nach einem konfigurierbaren 
Zeitpunkt (siehe unter Properties) zum nächsten 
erhältlichen Bild, wobei die manuelle Anwahl 
abgeschaltet wird
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➏ Properties

opens the Panel Properties window to change the 
Properties by double left mouse click on an entry.
The following entries are given:

➢ Aspect Ratio 
can be used to change the Aspect Ratio. Possible 
values are 0 (default, „Keep aspect ratio“), 1 
(„Noexpansion“) and 2 („Stretch“)

➢ Auto Cycle Image 
enables auto cycling of existing images with True, 
diables it with False (default)

➢ Auto Cycle Interval in s 
the duration between displaying two images when 
Auto Cycle Image is enabled. Default duration is 
15 seconds

➢ Auto Cycle Transition Fader on 
True enables the Faded Transition, False (default) 
disables it

➢ Back Overlay Activate 
enables a background overlay with True (default), 
disables it with False

➢ Back Overlay Colour 
the colour of the Background Overlay (R-G-B-A)

➎ Faded Transition

(nur aktiv, wenn Auto Cycle Image gewählt wurde)
schaltet einen sanften Übergang der automatisch 
wechselnden Bilder hinzu

ACHTUNG:
Unter Windows XP/Vista funktioniert unter bestimmten 
Umständen dieser sanfte Übergang nicht! Es wird daher 
empfohlen, Faded Transition nur unter Windows 7 zu 
nutzen!

➏ Properties

öffnet die Panel-Eigenschaften zum Setzen der Optionen 
per Doppelklick auf den jeweiligen Eintrag. 
Folgende Einträge stehen hierbei zur Verfügung:

➢ Aspect Ratio 
legt das anzuzeigende Seitenverhältnis fest. 
Mögliche Angaben sind: 0 (Standard, „Keep 
aspect ratio““), 1 („Noexpansion“) und 2 („Stretch“).

➢ Auto Cycle Image 
True schaltet die automatische Weiterschaltung 
vorhandener Bilder hinzu, False (Standard) 
schaltet diese ab.

➢ Auto Cycle Interval in s 
legt die Dauer fest, wie lange ein Bild während der 
automatischen Weiterschaltung angezeigt wird. 
Voreingestellt sind 15 Sekunden
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➢ Description: Back Colour 
the colour (R-G-B) of the description background 
that is displayed for a short time during manual 
image change

➢ Description: Text Colour 
the colour (R-G-B) of the description text that is 
displayed for a short time during manual image 
change

➢ Enable Custom Pictures 
enables displaying the Custom Pictures with True, 
enables the foobar2000 artreader with False 
(default)

➢ File extension order and Picture 1-5 
see chapter 2.5.2

➐ Configure

opens the Panels script (for advanced users only!)

➢ Auto Cycle Transition Fader on 
True aktiviert die „Faded Transition“, False 
(Standard) deaktiviert diese.

➢ Back Overlay Activate 
aktiviert mit True (Standard) ein Hintergrund-
Overlay, deaktiviert dieses mit False.

➢ Back Overlay Colour 
legt die Farbe des Overlay fest (R-G-B-A).

➢ Description: Back Colour 
legt die Farbe des Hintergrundes der 
Beschreibung fest (R-G-B), die bei manuellem 
Bildwechsel kurz eingeblendet wird.

➢ Description: Text Colour 
legt die Farbe der Beschreibung fest (R-G-B), die 
bei einem manuellem Bildwechsel kurz 
eingeblendet wird.

➢ Enable Custom Pictures 
aktiviert die Anzeige der benutzerdefinierten Bilder 
mit True, den foobar2000 artreader mit False 
(Standard).

➢ File extension order und Picture 1-5 
Siehe Kapitel 2.5.2

➐ Configure

ermöglicht den Einblick ins Script (nur für versierte User!)
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2.6 Spectral Analyzer In the middle of the configuration is a visualisation called 
Channel Spectrum Panel.

This panel is preconfigured to its maximum capacity and 
may increase CPU consumption!

To fit the channel spectrum to your needs, right-click on it 
and choose Configure.

If you have changed its settings and you're not satisfied 
with the result you can go back to configurations default 
setting by choosing the CSPdefault.csp from the 
...\foobar2000\themes\DarkOne\Others\Settings folder 
with the Import button.

Oben mittig über der Wiedergabeliste befindet sich ein 
Channel Spectrum Panel.

Dieses ist auf maximale Leistung voreingestellt, was zu 
einem erhöhten CPU-Verbrauch führt!

Wenn Sie die Einstellungen ändern möchten, 
rechtsklicken Sie bitte auf die Anzeige und wählen 
Configure.

Sollten Sie mit dem Ergebnis Ihrer Bemühungen nicht 
zufrieden sein, können Sie den „Auslieferungszustand“ 
des Panels jederzeit über die im Configure-Dialog 
befindliche Schaltfläche Import und Auswahl der Datei 
CSPdefault.csp aus dem Ordner
...\foobar2000\themes\DarkOne\Others\Settings
wiederherstellen.
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2.7 Menubar
     ❶          ❷    ❸    ❹ ❺       ❻      ❼

There's a Menubar above the Playlist views with 
additional buttons.

❶ MENU

opens the foobar2000 Menu with access to all menu 
entries

❷ Musiknote

jumps to the file that is now playing

❸ Stop-after-current

forces foobar2000 to stop playback after the now playing 
file

❹ Playback Order

opens a Menu that allows you to select the desired 
Playback order as followed:

➢ Default 
plays files in the order they are present in the 
Playlist

➢ Repeat (Playlist) 
repeats the active Playlist

➢ Repeat (Track) 
repeats the active file

➢ Random 
selects files randomly from the active Playlist, 
where files may be played more than once – 
sometimes repeated directly

➢ Shuffle (tracks) 

Über  den  Wiedergabelistenansichten  befindet  sich  die 
Menüleiste mit zusätzlichen Schaltflächen.

❶ MENU

öffnet das foobar2000 Menü mit Zugriff auf alle 
Menüeinträge

❷ Musiknote

springt in der Wiedergabeliste zu dem aktuell spielenden 
Lied

❸ Stop-after-current

weist foobar2000 an, nach dem aktuell spielenden Lied 
die Wiedergabe zu beenden

❹ Playback Order

öffnet ein Menü, aus der man die gewünschte 
Wiedergabefolge wie folgt auswählen kann:

➢ Default 
Wiedergabe der Titel in der Reihenfolge, in der sie 
sich in der Wiedergabeliste befinden

➢ Repeat (Playlist) 
wiederholt die aktive Wiedergabeliste

➢ Repeat (Track) 
wiederholt den aktiven Titel

➢ Random 
wählt Titel in zufälliger Reihenfolge aus der aktiven 
Wiedergabeliste aus, wobei Titel mehrfach – 
mitunter auch zufällig unmittelbar hintereinander – 
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selects files randomly from the active playlist. 
Different to the Random Playback Order every file 
will be played only once

➢ Shuffle (albums) 
selects a whole album randomly from the active 
Playlist

➢ Shuffle (folders) 
selects a whole folder randomly from the active 
Playlist

Beneath a tooltip the chosen Playback Order will be 
signalised by the displayed image in the Menubar.

❺ ELPlaylist

activates the default Playlist view (ELPlaylist, see 
Chapter 2.8.1)

❻ NG Playlist

activates the Columns UI NG Playlist (see Chapter 2.8.2)

❼ Mini Playlist/Big Cover Panel

activates the Mini Playlist view (see Chapter 2.8.3) on the 
left down side of the configuration, where the center 
Playlist view will be replaced by a big Cover Panel view.

gespielt werden können

➢ Shuffle (tracks) 
wählt Titel in zufälliger Reihenfolge aus der aktiven 
Wiedergabeliste aus, wobei anders als bei der 
Wiedergabefolge Random jeder Titel nur einmal 
gespielt wird

➢ Shuffle (albums) 
wählt ganze Alben in zufälliger Reihenfolge aus 
der aktiven Wiedergabeliste

➢ Shuffle (folders) 
wählt ganze Ordnerinhalte in zufälliger 
Reihenfolge aus der aktiven Wiedergabeliste

Die ausgewählte Wiedergabefolge wird neben einem 
Tooltip auch durch das angezeigt Bild in der Menüleiste 
signalisiert.

❺ ELPlaylist

aktiviert die Standard-Wiedergabelistenansicht 
(ELPlaylist, siehe Kapitel 2.8.1)

❻ NG Playlist

aktiviert die Columns UI NG Playlist (siehe Kapitel 2.8.2)

❼ Mini Playlist/Big Cover Panel

aktiviert die Mini-Wiedergabelistenansicht (siehe Kapitel 
2.8.3) am linken unteren Rand der Konfiguration, wobei 
die Wiedergabelistenansicht in der Mitte durch das Cover 
Panel in Großansicht ersetzt wird.
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2.8 Playlist views DarkOne has different Playlist views to offer the user an 
acceptable flexibility in the appearance of the 
configuration.

DarkOne ist mit mehreren Wiedergabelistenansichten 
ausgestattet, um dem Benutzer ausreichend Flexibilität in 
der Darstellung der Konfiguration zu bieten.

2.8.1 ELPlaylist The ELPlaylist is the default Playlist view of the 
configuration.

I've tried to make the usage and possibility of end-users 
modification of the ELPlaylist as easy as possible, but 
Title-Formatting skills are still necessary!

Die ELPlaylist ist die Standard-Wiedergabelistenansicht 
dieser Konfiguration.

Ich habe versucht, die Anpassung dieser an die Wünsche 
des Endverbrauchers so einfach wie möglich zu 
gestalten. Dennoch sind auch hier Kenntnisse im sog. 
Title Formatting notwendig!

2.8.1.1 Grouping and sorting The Playlist view is set up to group by Artist, Album and – 
if there is more than one disc and the files are correctly 
tagged – disc number by default. If none of the above 
tags is present in the files, they are grouped by the name 
of the folder they are stored in.

The sorting in the Playlist complies with the order the files 
are stored in their folders. That for it is recommended that 
the file names are beginning with their track numbers!

If you want to change these default settings please do a 
right mouse click in the Playlist and select Settings → 
Grouping tab.

Standardmäßig ist die Wiedergabeliste so eingestellt, 
dass sie nach Künstler, Album und – falls mehrere Discs 
zu einem Album gehören und eine entsprechende 
Information in den Tags vorhanden ist - Discnummer 
gruppiert. Sollte keine dieser Informationen vorliegen, 
wird nach dem Namen des Ordners, in dem sich die Titel 
befinden, gruppiert.

Die Sortierung in der Wiedergabeliste entspricht dabei 
der Reihenfolge, in der die Titel im Ordner liegen. Es ist 
daher ratsam, die Dateinamen der Lieder mit der 
Titelnummer beginnen zu lassen!

Möchten Sie diese Grundeinstellungen ändern, klicken 
Sie bitte mit der rechten Maustaste in die Wiedergabeliste 
und wählen Sie Settings → Registerkarte Grouping.
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In the red framed text box in the upper illustration on the 
left please type-in your desired grouping scheme.

In the blue framed text box in the upper illustration on the 
left please type-in your desired Sort format.

There is the possibility to set up additional Sort format in 
the ELPlaylist or edit the already existing presets.

You'll find this possibility under Settings → Misc tab → 
Additional sort format for context menu.

Please give your new Sort format an expressive name 
under Display name (orange framed text box in the lower 
illustration on the left) and type-in your desired sorting 
string in Sort format (green framed text box in the lower 
illustration on the left).

Click add after you finished adding your Sort fomat and it 
will be added to the list.

To edit an existing preset select it from the Display name 
list, edit the Sort format and hit the update button.

After hit OK your changes are stored and you can use 
them.

Im in der nebenstehenden obigen Abb. rot umrandeten 
Textfeld geben Sie bitte Ihr Gruppierungsschema ein.

Im in der nebenstehenden obigen Abb. blau umrandeten 
Textfeld geben Sie bitte Ihr Sortierungsschema ein.

Es gibt noch die Möglichkeit, weitere, von der Standard-
sortierung abweichende Sortierungsschemen anzulegen 
bzw. die bereits vorgegebenen zusätzlichen Sortierungs-
schemen zu ändern.

Diese Möglichkeit finden Sie unter Settings → Register-
karte Misc → Additional sort format for context menu.

Dazu vergeben Sie unter Display name (orange 
umrandetes Textfeld in der unteren nebenstehenden 
Abb.) einen aussagekräftigen Namen und tippen unter 
Sort format (grün umrandetes Textfeld in der unteren 
nebenstehenden Abb.) das gewünschte Sortierungs-
schema ein.

Nach einem Klick auf die Schaltfläche add ist das neue 
Sortierungsschema angelegt.

Sie können ein bereits angelegtes Sortierungsschema 
ändern, indem Sie es aus der Display name Liste aus-
suchen, das Sort format ändern und die Schaltfläche 
update betätigen.

Nach einem Klick auf die Schaltfläche OK stehen Ihnen 
die Änderungen in Ihrer Wiedergabeliste zur Verfügung.

27



2.8.1.2 Transparency for the Popup window If you move the mouse over a track/album in the default 
Playlist view, a popup-window with informations about the 
Playlist entry the mouse points to will open. You can 
display an image besides this informations (see chapter 
2.8.1.3).Since transparency of the popup-window 
depends on your Windows Visual Style it may be 
necessary to tell the popup-window the “transparency 
colour”. Otherwise it may happen that the popup-window 
will get an ugly white border that doesn't fits to the 
appearance of the configuration. 
To tell the popup-window the correct transparency colour, 
right-click in the Playlist view and select Settings → Misc 
tab.

Zeigt die Maus auf die Wiedergabelistenansicht, öffnet 
sich ein kleines Popup-Fenster mit Informationen zum 
Album oder zum Lied, auf das der Mauszeiger gerade 
gerichtet ist.
Neben den Informationen kann auch ein Bild in diesem 
Popup-Fenster angezeigt werden (siehe Kapitel 2.8.1.3).
Da die Transparenz des Popup-Fensters vom verwen-
deten Windows Visual Style abhängt, ist es unter Um-
ständen notwendig, dem Fenster die „Transparenz-
Farbe“ mitzuteilen, da das Popup-Fenster ansonsten u. 
U. Einen weißen Rand übrig behält.
Um der ELPlaylist die passende Transparenz-Farbe 
mitzuteilen, gehen Sie bitte über Rechtsklick auf die Wie-
dergabeliste in deren Settings → Registerkarte Misc.

Click on the colour... button and select the transparent 
colour as illustrated on the left by a single click on the red 
framed area on the down left side.

Confirm your action with OK to return to the Misc tab.

You can change the degree of transparency of the 
popup-window with Popup opacity (between 0 and 255).

After hit OK your changes are applied to your Playlist 
view and you'll leave the Settings dialog.

Klicken Sie bitte auf die Schaltfläche Colour...und wählen 
Sie in der sich öffnenden Farbauswahl das in der neben-
stehenden Abb. rot umrandete Kästchen.

Bestätigen Sie Ihre Auswahl mit OK, so dass Sie zu der 
Ansicht der Registerkarte Misc zurückkehren.

Bei Popup opacity können Sie zusätzlich noch 
bestimmen, wie stark der Transparenz-Effekt sich auf das 
Popup-Fenster auswirken soll (zwischen 0 und 255).

Mit einem Klick auf die Schaltfläche OK bestätigen Sie 
Ihre Änderungen und verlassen den Settings-Dialog.
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NOTE:
You must do these changes for the Mini-Playlist (the right 
button above the playlist) separately, because it has a 
popup-window too.

HINWEIS:
Sie müssen diese Einstellungen auch für die Mini-
Wiedergabelistenansicht (erreichbar durch einen Klick 
auf die Schaltfläche ganz rechts oberhalb der 
Wiedergabeliste) vornehmen, da auch diese ein Popup-
Fenster aufweist.

2.8.1.3 Field definition To fit the ELPlaylists behaviour to your needs please 
right-click in it, select Settings → Field definition tab and 
change an entry by double-clicking on it and editing the 
content of the Definition box.

Zur Anpassung der ELPlaylist an Ihre persönlichen 
Bedürfnisse, gehen Sie bitte über Rechtsklick auf die 
Wiedergabelistenansicht in deren Settings → 
Registerkarte Field definition, doppelklicken Sie auf den 
jeweiligen Eintrag und ändern Sie den Inhalt der Textbox 
Definition.

❶ Global Settings

➢ MAIN.COLOUR
changes the colour format of ELPlaylist (R-G-B)

➢ CONFIG.PATH
path to the DarkOne configuration folder

➢ POPUP.ART
the kind of artwork that has to be given by the 
foobar2000 artreader for diplaying in the Popup 
window (see also Chapter 2.5.1).
Possible entries are: 
artist, front, back, disc and icon

❶ Globale Einstellungen

➢ MAIN.COLOUR
ändert das Farbschema der ELPlaylist (R-G-B)

➢ CONFIG.PATH
der Pfad zum DarkOne Konfigurationsordner

➢ POPUP.ART
Angabe des Bildtyps, das vom foobar2000 
artreader für die Darstellung im Popup-Fenster 
bereitgestellt werden soll (siehe auch Kapitel 
2.5.1).
Mögliche Angaben sind: 
artist, front, back, disc und icon
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❷ Columns-Management

➢ COLUMNS.FONT.SIZE
defines the font size of the font style preconfigured 
in Columns UI → Colours and Fonts → Fonts tab 
(see Chapter 3.2)

➢ COLUMNS.FONT.OPTION
defines the font option of the font style 
preconfigured in Columns UI → Colours and Fonts 
→ Fonts tab (see Chapter 3.2)
Selectable (can be combined):
bold, italic, underline und strikeout

➢ COLUMN.X.ON
(for Column 2 and 3 only!)
activates the respective Column with 1, 
deactivates it with 0 (default)

➢ COLUMN.X.TEXT
to type in the Text or Title Formatting String, that 
is desired in the respective Column

➢ COLUMN.X.SHADOW
activates a shadow for the respective Column with 
1, deactivates it with 0

➢ COLUMN.X.ALIGN
defines the horizontal align of the respective 
Column with the following possible entries:
left, right and hcenter

❷ Spalten-Management

➢ COLUMNS.FONT.SIZE
legt die Schriftgröße der über Columns UI → 
Colours and Fonts → Registerkarte Fonts 
voreingestellten Schriftart fest (siehe Kapitel 3.2)

➢ COLUMNS.FONT.OPTION
legt die Option der über Columns UI → Colours 
and Fonts → Registerkarte Fonts voreingestellten 
Schriftart fest (siehe Kapitel 3.2)
Zur Auswahl stehen (können kombiniert werden): 
bold, italic, underline und strikeout

➢ COLUMN.X.ON
(nur für die Spalten 2 und 3!)
aktiviert die jeweilige Spalte mit 1, deaktiviert 
diese mit 0 (Standard)

➢ COLUMN.X.TEXT
hier wird der Text oder Title Formatting String, der 
in der jeweiligen Spalte gewünscht ist, 
eingegeben

➢ COLUMN.X.SHADOW
aktiviert einen Schatten in der jeweiligen Spalte 
mit 1, deaktiviert diesen mit 0

➢ COLUMN.X.ALIGN
legt die horizontale Ausrichtung einer Spalte fest, 
wobei folgende Einträge möglich sind:
left, right und hcenter
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➢ COLUMN.X.WIDTH
defines the width of the respective Column (the 
width of the standard COLUMN.ONE is adjusted 
automatically according to the chosen width of the 
Columns COLUMN.TWO and/or 
COLUMN.THREE)

❸ Rating Options

➢ RATE.DISPLAY
defines what to display in the rating area of the 
Playlist by selecting one of the following entries 
for Definition:
0 = displays ratings in white (Standard)
1 = displays Auto-Ratings in blue
2 = displays Playcounts in green

➢ RATE.BAR.MODE
switches the display of the rating area to a bar 
with 1, back to the usual stars with 0 (default)

➢ PLAYCOUNT.LIMIT
defines the amount of play counts a song has to 
be left to display all stars/the whole bar in 
RATE.DISPLAY mode 2.

➢ COLUMN.X.WIDTH
legt die Breite der jeweiligen Spalte fest (die 
Breite der Spalte COLUMN.ONE passt sich 
automatisch an die gewählten Werte für die 
Spalten COLUMN.TWO und/oder 
COLUMN.THREE an)

❸ Rating Optionen

➢ RATE.DISPLAY
legt fest, was im Rating-Bereich angezeigt werden 
soll, wobei folgende Möglichkeiten zur Eingabe 
unter Definition Verfügung stehen:
0 = Anzeige von Bewertungen in weiß (Standard)
1 = Anzeige des Auto-Ratings in blau
2 = Anzeige der Abspielhäufigkeit in grün

➢ RATE.BAR.MODE
stellt die Anzeige mit 1 auf einen Balken um, mit 0 
(Standard) auf die üblichen Sterne

➢ PLAYCOUNT.LIMIT
legt fest, nach wie vielen Abspielvorgängen im 
RATE.DISPLAY Modus 2 alle Sterne bzw. der 
gesamte Balken aufleuchten soll.
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2.8.2 NG Playlist The Columns UI NG Playlist is affiliated to the DarkOne 
configuration as second Playlist view.

Please read the Columns UI Documentation for more 
details about the options of the NG Playlist than 
mentioned here.

Die Columns UI NG Playlist ist als zweite Wiedergabe-
listenansicht in die DarkOne-Konfiguration aufgenommen 
worden.
Über diese Bedienungsanleitung hinausgehende Details 
zu den Optionen der NG Playlist entnehmen Sie bitte der 
Columns UI Dokumentation.

2.8.2.1 Album Art If you want to display Album Art in the NG Playlist, please 
hit the MENU button and navigate to File → Preferences 
→ Columns UI → Playlist view → General tab.

At the bottom in the Artwork (NG Playlist only) area 
please activate Display artwork in groups.

To select which images have to be displayed navigate to 
Columns UI → Artwork tab.

If you want to use the foobar2000 artreader for displaying 
album art in the NG playlist enable Embedded and 
external artwork below Built-in foobar2000 artwork reader 
mode.

To display an alternative image when no album art can 
be found via foobar2000 artreader, please navigate to 
MENU → File → Preferences → Display and set a path to 
a stub image for the Front cover (see also chapter 2.5.1).

It may be necessary to restart foobar2000 to take effect.

Um eine Coveranzeige in der NG Playlist zu ermöglichen, 
gehen Sie bitte über die Schaltfläche MENU zu File → 
Preferences → Columns UI → Playlist view → 
Registerkarte General.

Ganz unten im Bereich Artwork (NG Playlist only) 
aktivieren Sie bitte Display artwork in groups.

Um nun auszuwählen, welche Bilder angezeigt werden 
sollen, gehen Sie bitte in den Preferences zu Columns UI 
→ Registerkarte Artwork.

Wählen Sie bei Built-in foobar2000 artwork reader mode 
bitte Embedded and external artwork aus.

Um ein Ersatzbild anzeigen zu lassen, falls kein 
passendes Bild über den foobar2000 Artreader verfügbar 
ist, müssen Sie unter MENU → File → Preferences → 
Display ein sog. Stub image setzen (siehe dazu auch 
Kapitel 2.5.1).

Ein evtl. foobar2000 Neustart kann erforderlich sein.
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2.8.2.2 Grouping To synchronize the grouping in NG Playlist and the 
ELPlaylists (Main Playlist view and Mini Playlist) you'll 
find a NG Playlist Grouping.txt in the folder 
...\foobar2000\themes\DarkOne\Others\Settings that 
contains a suitable Title-Formatting string.

Please copy this script preset to MENU → File → 
Preferences → Columns UI → Playlist view → Grouping 
tab by double-clicking on the existing preset and 
overwriting it with the copied content.

Um die Einträge in der NG Playlist synchron mit der 
ELPlaylist zu gruppieren, finden Sie in dem Ordner 
...\foobar2000\themes\DarkOne\Others\Settings die Datei 
NG Playlist Grouping.txt mit einem passenden Title-
Formatting String.

Kopieren Sie diesen bitte als Script-Preset unter MENU → 
File → Preferences → Columns UI → Playlist view → 
Registerkarte Grouping, indem sie auf das vorhandene 
Preset doppelklicken und mit dem kopierten Inhalt 
überschreiben.

2.8.2.3 Rating Display To fit the display of the rating area to your needs please 
go to MENU → File → Preferences → Columns UI → 
Playlist view → Columns, select the Column Rating → 
Scripts → Display tab

➢ $puts(rating.mode,0)
change the 0 (Rating) to 1 (Auto-Rating) or 2 
(Playcounts), if its desired

➢ $puts(count.limit,50)
change the 50 to the desired amount of play 
counts, that are necessary to display all stars in 
rateing.mode 2

Zum Anpassen der Rating-Anzeige gehen Sie bitte über 
MENU → File → Preferences → Columns UI → Playlist 
view → Columns, wählen Sie die Column Rating → 
Registerkarte Scripts → Display.

➢ $puts(rating.mode,0)
ändern Sie die 0 (Rating) auf 1 (Auto-Rating) oder 
2 (Playcounts), wenn Sie deren Anzeige wünschen

➢ $puts(count.limit,50)
ändern Sie die 50 auf die gewünschte Zahl an 
Abspielvorgänge, die nötig sind, um im 
rating.mode 2 alle Sterne aufleuchten zu lassen
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2.8.3 Mini Playlist/Big Cover view With a single click on the button for the Mini-Playlist view 
(see illustration on the left) the Playlist view and the 
Cover Panel will swap their positions.

The Cover Panel will now offer more details, but the 
Playlist will be a limited version of an ELPlaylist.

The configuration of the Mini Playlist view is similar with 
the ELPlaylist (please read chapter 2.8.1 to configure 
Mini Playlist view) but offers only limited options.

The Cover Panel is the same as described in chapter 2.5 
and should already be configured.

Mit Betätigung der Schaltfläche für die Mini- Wiedergabe-
listenansicht (siehe Abb. links) tauschen Wiedergabe-
listenansicht und Cover Panel die Plätze.

Somit wird das Cover Panel zu einer detaillierteren 
Ansicht, die Wiedergabeliste jedoch zu einer einge-
schränkten Version der ELPlaylist.

Die Konfiguration der Mini-Wiedergabelistenansicht ist 
identisch mit der der ELPlaylist (lesen Sie dazu bitte 
Kapitel 2.8.1). Nur dass sie weniger Konfigurations-
optionen bietet.

Das nun in der Mitte befindliche Cover-Panel ist hingegen 
identisch mit dem unter Kapitel 2.5 beschriebenen und 
bereits konfiguriert sein.
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2.9 Volume Control and additional  
buttons

The CONSOLE button opens the foobar2000 console, 
that offers valuable informations while ripping CD's or 
about occurred errors.

STATUSPANE and STATUSBAR opens/closes the 
associated bar.

With the volume control you can adjust the volume with 
the mouse wheel or the left mouse button.
Volume changes are displayed with a lightened position 
indicator for about three seconds and as value in the 
Display (see chapter 2.4.1) on the left side of the 
configuration.

You can select Volume Mute with a right-mouse-click on 
the volume control. The position indicator will turn to red 
as long as the volume is muted.

Informations about functions and options of the Quick 
Search Toolbar can be taken from their documentation.

Mit der Schaltfläche CONSOLE öffnen Sie die 
foobar2000-Konsole, die z. B. beim Rippen einer CD oder 
zur Fehlererkennung und -behebung nützliche Informati-
onen liefert.

STATUSPANE und STATUSBAR öffnen/schließen die 
zugehörige Leiste.

Über den Lautstärkeregler können Sie mit dem Mausrad 
oder der linken Maustaste bequem die Lautstärke 
ändern, wobei für drei Sekunden die Aktivität des 
Lautstärkereglers mit einem Aufleuchten der Positions-
Markierung und der aktuellen Lautstärke im Display 
(siehe Kapitel 2.4.1) auf der linken Seite der 
Konfiguration angezeigt wird.

Mit einem Rechtsklick auf den Lautstärkeregler können 
Sie die Lautstärke über Volume Mute stumm schalten.
Die Positionsmarkierung zeigt dann automatisch auf das 
Minimum und wechselt ihre Farbe für die Dauer der 
Stummschaltung auf rot.

Informationen zu den Funktionen und Optionen der 
ebenfalls in diesem Bereich befindlichen Quick Search 
Toolbar entnehmen Sie bitte deren Dokumentation.
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2.10 Panel switcher (PSS „Tabs“) The right hand side of the configuration is occupied by a 
Panel Stack Splitter, which is configured as Panel 
switcher.

This Panel switcher will comfortably allow the user to use 
the preconfigured Panels (see chapter 2.10.1), to 
manage them or to add additional desired Panels to the 
configuration (see chapter 2.10.2).

But the maximum count of available Panels is limited to 
only eight. Unused Panel places are named as RES.

Die rechte Seite der Konfiguration nimmt hauptsächlich 
ein Panel Stack Splitter ein, der als Panel-Umschalter 
konfiguriert wurde.

Dieser Panel Umschalter soll dem Benutzer ermöglichen, 
auf bequeme Weise die vorkonfigurierten Panel (siehe 
dazu Kapitel 2.10.1) zunutzen, zu verwalten oder 
zusätzlich erwünschte Panel in die Konfiguration 
einzubauen (siehe Kapitel 2.10.2). Die maximale Anzahl 
an nutzbaren Panels ist jedoch auf acht beschränkt. 
Ungenutzte Panelplätze sind mit RES bezeichnet.

2.10.1 Preconfigured Panels Seven from the eight available Panels are already 
preconfigured. However, you can move, replace or 
remove them from the configuration (see chapter 2.10.2).

These Panels will be described in the following 
subchapters.

Sieben der nutzbaren acht Panelplätze sind bereits 
vorkonfiguriert, können jedoch jederzeit verschoben, 
ersetzt oder aus der Konfiguration entfernt werden (siehe 
Kapitel 2.10.2).

Die bereits eingebauten Panel werden in den folgenden 
Unterkapiteln beschrieben.

2.10.1.1 PL – Playlist switcher Its configuration can be done in MENU → File → 
Preferences → Columns UI → Playlist switcher.

Its appearance can be changed - after activating the 
option that is red framed in the illustration on the left – in 
the Scriptbox. For more information please read its 
Documentation and its special Title-Formatting-
Reference.

Die Konfiguration des Columns UI Playlist switchers 
erreichen Sie unter MENU → File → Preferences → 
Columns UI → Playlist switcher.
Das Erscheinungsbild können Sie nach Aktivierung der in 
der nebenstehenden Abb. rot umrandeten Option in der 
darunterliegenden Scriptbox anpassen. Näheres dazu 
entnehmen Sie bitte der Dokumentation und der 
speziellen Titleformatting-Referenz.
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2.10.1.2 LIB – Library

   ❶     ❷         ❸     ❹
Here you'll find different options to show the content of 
your Media Library, which – of course – must be 
configured before.

Go to MENU → File → Preferences → Media Library and 
add your music folder withe the Add... button to your 
Library.

There are four buttons with the following functions 
available for using this Panel:

❶ AL – Album List Panel

Here you can view the content of your Media Library in a 
user defined or preconfigured explorer-like tree structure.
Its configuration can be done on the MENU → File → 
Preferences → Media Library → Album List Panel page. 
You'll need Title-Formatting-skills to define newViews!

❷ FIL – Filter

Here you can filter your Media Library after defined 
parameters.
The filters configuration can be done on.the MENU → File 
→ Preferences → Columns UI → Filter tab.
For more informations please read the Online-
Documentation (still under construction, though...).

Hier finden Sie verschiedene Optionen zur Anzeige des 
Inhalts Ihrer Medienbibliothek, die zuvor natürlich 
angelegt werden muss.

Gehen Sie dazu unter MENU → File → Preferences → 
Media Library und fügen Sie über die Schaltfläche Add... 
Ihren Musikordner hinzu.

Zur Nutzung dieses Panels stehen Ihnen vier Schalt-
flächen zur Verfügung, die folgende Funktionen 
aufweisen:

❶ AL – Album List Panel

Hiermit können Sie den Inhalt Ihrer Medienbibliothek in 
einer benutzerdefinierten oder voreingestellten 
Baumstruktur anzeigen lassen.
Dessen Konfiguration können Sie unter MENU → File → 
Preferences → Media Library → Album List Panel 
vornehmen. Sie benötigen Title-Formatting-Kenntnisse, 
um neue Ansichten (Views) definieren!

❷ FIL – Filter

Hiermit können Sie den Inhalt Ihrer Medienbibliothek 
nach vorgewählten Kriterien filtern.
Die Konfiguration der Filter können Sie unter MENU → 
File → Preferences → Columns UI → Registerkarte Filter 
vornehmen.
Näheres hierzu entnehmen Sie bitte der Online-
Dokumentation (die leider noch im Aufbau ist...).
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❸ New

With this button you can view files that are added to your 
Media Library in a predefined period in a separate 
window. You'll find help with the ? button in this window.

❹ Find

Opens the Media Library Search to browse your library in 
a separate window. You'll find help with the ? button in 
this window.

❸ New

Mit dieser Schaltfläche können Sie sich die in einem 
vordefinierten Zeitraum neu in Ihre Medienbibliothek 
hinzugefügten Titel in einem separaten Fenster anzeigen 
lassen. Hilfe erhalten Sie über die ? Schaltfläche in 
diesem Fenster.

❹ Find

Öffnet die Medienbibliothekssuche in einem separaten 
Fenster, mit der Sie Ihre Medienbibliothek durchsuchen 
können. Hilfe erhalten Sie über die ? Schaltfläche in 
diesem Fenster.

2.10.1.3 ESP - EsPlaylist The EsPlaylist is merely „abused“ as a „Graphical 
Browser“ here ;)

With a single left mouse click on a Cover the relevant files 
will be chosen in the centered Playlist view.

With a double left mouse click on a Cover the relevant 
files will start to play.

With a middle mouse click on a Cover the relevant files 
will be opened directly in the EsPlaylist, while a further 
middle mouse click on the „Group Header“ will force 
EsPlaylist to return to the Cover overview.

If you want to change the configuration of EsPlaylist 
please read its documentation foo_uie_esplaylist.txt, that 
you'll find here:%appdata%\foobar2000\user-

components\foo_uie_esplaylist

Die EsPlaylist wird hier lediglich als „Graphical Browser“ 
missbraucht ;)
Hierbei wird durch einen Klick mit der linken Maustaste 
auf eines der abgebildeten Cover die zugehörigen Titel in 
der mittigen Wiedergabelistenansicht ausgewählt.
Mit einem Doppelklick auf das abgebildete Cover werden 
die zugehörigen Titel abgespielt.
Ein Klick auf ein Cover mit der mittleren Maustaste öffnet 
die zugehörigen Titel direkt in der EsPlaylist, die mit 
einem weiteren Klick mit der mittleren Maustaste auf den 
„Group Header“ wieder zu einer Cover-Übersicht wird.
Möchten Sie die Konfiguration der EsPlaylist ändern, 
lesen Sie bitte deren Dokumentation 
foo_uie_esplaylist.txt, die Sie unter %appdata

%\foobar2000\user-components\foo_uie_esplaylist finden.
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2.10.1.4 LYR – Lyrics Panel You can view Lyrics stored in the files Metadata (Tags) 
with the Lyrics Panel. Supported fields are LYRICS and 
UNSYNCED LYRICS.

You can also view external Lyrics files in the Lyrics Panel 
(*.txt und *.lrc), when you already typed in the paths to 
them in the Panel Properties (see below).

Lyrics with timestamps will be displayed, cleared from 
timestamps and unsynced only!

Following functions are available:

❶ Mouse actions

(only available during playback)
➢ Left mouse button

hold the button to drag and seek in Lyrics greater 
than the Lyrics Panels height.

➢ Middle mouse button
to refresh the Lyrics Panel and reload the Lyrics

➢ Right mouse button
activates the context menu with the following 
entries:
● Refresh
same as middle mouse button

In der Songtextanzeige können Songtexte in den 
Metadaten einer Datei (Tags) angezeigt werden. 
Unterstützt werden die Tags LYRICS und UNSYNCED 
LYRICS.

Des weiteren lassen sich auch externe Textdateien in der 
Songtextanzeige darstellen (*.txt und *.lrc), wenn Sie in 
den Panel Properties deren Pfad angegeben haben 
(siehe unten).

Songtexte mit Zeitmarken können zwar um die 
Zeitmarken bereinigt angezeigt werden, jedoch nicht 
synchronisiert!

Folgende Funktionen stehen Ihnen zur Verfügung:

❶ Maus-Funktionen

(nur aktiv während eines Abspielvorganges)
➢ Linke Maustaste

Mit gedrückt gehaltener Maustaste kann die 
Ansicht der Texte, die länger sind als die Höhe des 
Panels, im Panel repositioniert werden.

➢ Mittlere Maustaste
lädt den Songtext (Refresh)

➢ Rechte Maustaste
aktiviert das Kontextmenü mit folgenden 
Einträgen:
● Refresh
gleiche Funktion wie mittlere Maustaste
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● Auto-scroll
to scroll Lyrics automatically over the Panels 
height
● Fading
(only active when Auto-scroll is enabled)
turns on a fading effect for auto scrolling only
● Properties
opens the Panels Properties window to get 
optional settings
● Configure
opens the Panels script
for advanced users only!

❷ Loading external Lyric files

As described above the Lyrics Panel will not only display 
embedded Lyrics but external, too. To load this external 
files the Lyrics Panel needs to know the path and naming 
format of them.

Please do a right mouse click to go to the context menu 
and select Properties.

Do a double left mouse click on the entry Lyrics Path and 
type in the path and naming format of the external Lyric 
files. Wildcards and Titleformatting are possible.

● Auto-scroll
um Songtexte automatisch über die Höhe des 
Panels ablaufen zu lassen
● Fading
(nur aktiv, wenn Auto-scroll gewählt wurde)
schaltet einen Fading-Effekt beim Auto-scrolling 
hinzu
● Properties
öffnet das Fenster mit den Panel-Eigenschaften, 
um optionale Einstellungen vorzunehmen
● Configure
ermöglicht Einblick in das Script des Panels
nur für versierte Benutzer!

❷ Externe Songtexte laden

Wie bereits erwähnt, kann die Songtextanzeige neben 
Songtexten aus den Metadaten einer Datei auch externe 
Songtexte anzeigen. Um diese Songtexte laden zu 
können, muss dem Panel natürlich mitgeteilt werden, 
unter welchem Pfad und unter welchem Namensschema 
diese Texte zu finden sind.

Gehen Sie dazu mit einem Klick der rechten Maustaste 
ins Kontextmenü und wählen Sie Properties.

Doppelklicken Sie auf den Eintrag Lyrics Path und geben 
Sie den Pfad und das Namensschema ihrer externen 
Songtexte ein. Hierbei sind Wildcards und Titleformatting 
möglich.

40

http://wiki.hydrogenaudio.org/index.php?title=Foobar2000:Titleformat_Reference
http://wiki.hydrogenaudio.org/index.php?title=Foobar2000:Titleformat_Reference


❸ Padding

You can add padding between the Lyrics and the Panel 
border with a double left mouse click on the according 
entries in the Properties window.

❹ Customize the Font Style

The Font Style of the Lyrics Panel is like the rest of the 
configurations Font Style predefined by Columns UI → 
Colours and Fonts → Fonts tab → Common (list items).

If you want to change this Font Style for the Lyrics Panel 
only you will have to go to the Properties window again 
and do a double left mouse click on the entry UI Font: 
Override to change it from False to True.

Now do a double left mouse click on the entry UI Font: 
Style and type in the desired Font Style like this:
Font, Size in Pixel, Style, for instance: Arial, 11, 1.

Please note that the Font size has to be set in Pixels not 
in Points as usual! 4 Pixels corresponds to 3 Points.
So Arial 8pt has to be typed in as 11.

For the Font Style you can use 0 for normal, 1 for bold, 2 
for italic, 3 for bold/italic, 4 for underlined and 8 for 
strikeout.

❸ Padding

Ebenfalls über den Kontextmenü-Eintrag Properties 
können Sie mit einem Doppelklick auf den zugehörigen 
Eintrag einen Abstand des Textes zum Panelrand setzen.

❹ Schriftart anpassen

Die Schriftart der Songtext-Anzeige wird wie für die 
gesamte Konfiguration durch Columns UI → Colours and 
Fonts → Registerkarte Fonts → Common (list items) 
vorgegeben.

Möchten Sie diese nur für die Songtext-Anzeige ändern, 
gehen Sie bitte über den Kontextmenü-Eintrag in die 
Properties und doppelklicken Sie auf den Eintrag UI Font: 
Override, so dass False in True geändert wird.

Doppelklicken Sie nun auf den Eintrag UI Font: Style und 
geben Sie die gewünschte Schrift wie folgt ein:
Schriftart, Schriftgröße in Pixel, Schriftschnitt, z. B.:
Arial, 11, 1.

Sie sollten dabei beachten, dass die Schriftgröße nicht in 
Punkten – wie üblicherweise – sondern in Pixeln 
anzugeben ist! 4 Pixel entsprechen dabei 3 Punkten. Die 
Schriftgröße 8pt wäre somit also mit der Zahl 11 
anzugeben.

Für den Schriftschnitt stehen Ihnen 0 für normal, 1 für 
fett, 2 für kursiv, 3 für fett/kursiv, 4 für unterstrichen und 8 
für durchgestrichen zur Verfügung.
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❺ Downloading Lyrics from the Net

It is possible to load lyrics from the internet with 
additional, optional components. Since these components 
are in alpha-state or unstable they're not included in the 
DarkOne download.

But the Lyrics Panel is already preconfigured for the use 
of foo_lyricsgrabber2 and/or foo_lyricsdb, who will both 
store the found Lyrics in the files Metadata (Tags) only.

Should one of these two components already exists in 
your user-components directory there will be an 
additional entry called Lyrics Search Command 
automatically in the panels Properties window with a 
suggestion for a suitable download command. Should 
both exist in your components folder the Lyricsgrabber2 
will have priority over foo_lyricsdb.

You'll also have the additional command Online Search in 
the Panels context menu..

If you install one of these two components subsequently 
and don't find the necessary entries in the Properties 
window or the context menu, please go to the Properties 
window, select  and hit Clear to make the panel 
recognizing the new component(s). But this will force you 
to enter your path and naming scheme to external lyrics 
files again.

❺ Songtexte aus dem Internet herunterladen

Optional ist es auch möglich, Songtexte aus dem Internet 
herunterzuladen. Die hierfür benötigten Komponenten 
sind jedoch instabil oder im Alpha-Stadium befindlich und 
sind deshalb nicht im DarkOne Download enthalten.

Die Songtext-Anzeige ist jedoch für die Nutzung von 
foo_lyricsgrabber2 und/oder foo_lyricsdb vorkonfiguriert, 
die die gefundenen Songtexte einer Datei jedoch 
ausschließlich in die Metadaten (Tags) schreiben.

Sollte sich bereits eines dieser beiden Komponenten in 
Ihrem user-components-Ordner befinden, wird 
automatisch ein Eintrag namens Lyrics Search Command 
im Properties-Fenster erstellt und bereits ein Vorschlag 
für den Downloadbefehl gegeben, wobei der 
Lyricsgrabber2 Priorität vor foo_lyricsdb genießt.

Zudem wird das Kontextmenü um den Eintrag Online 
Search ergänzt.

Sollten Sie eines der beiden optionalen Komponenten 
nachträglich installieren und weder den Eintrag im 
Properties-Fenster noch die Erweiterung des 
Kontextmenüs erhalten, gehen Sie bitte ins Properties-
Fenster und betätigen Sie die Schaltfläche Clear, um die 
Einträge neu zu erstellen. Dadurch sind Sie aber 
gezwungen den Pfad und das Namensschema Ihrer 
externen Songtexte erneut einzugeben.
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2.10.1.5 BIO – Biography View Panel The BIO button shows the Biography View Panel that 
displays informations and images for the selected or now 
playing file.

These informations are loaded from last.fm  .   You can 
select your local last.fm server in MENU → File → 
Preferences → Tools → Biography Server → Last.fm → 
General tab.

The Panel offers extensive Properties and Settings, for 
instance if and where to download biographies and 
images on your local harddisc.

Unfortunately there is no reasonable English 
documentation for this component developed by a 
Japanese, so I advice you to play with its options ;).

Über die Schaltfläche BIO gelangen Sie an das 
Biography View Panel, welches Ihnen Informationen und 
Bilder zum ausgewählten oder spielenden Lied anzeigt.

Diese Informationen bezieht das Panel von last.fm. Den 
Server können Sie unter MENU → File → Preferences → 
Tools → Biography Server → Last.fm → Registerkarte 
General umstellen.

Das Panel bietet umfangreiche Einstellungs-
möglichkeiten, u. a. können sie festlegen, ob und wohin 
geladene Bilddateien/Biografien gespeichert werden 
sollen.

Eine vernünftige deutsch- oder englischsprachige 
Dokumentation des von einem japanischen Entwickler 
stammenden Panels ist leider nicht verfügbar. Ich kann 
hier also nur anraten ein bisschen mit den angebotenen 
Optionen zu spielen...

2.10.1.6 DET Item Details Panel The DET button shows an Item Details Panel which is 
preconfigured to display Performer and Comment Tags of 
the now playing file.

If you want to change this configuration please do a right 
mouse click at the DET button and select Splitter 
Settings. Select DET in the PanelList and hit the 
Configure button.

Über die Schaltfläche DET gelangen Sie an ein Item 
Details Panel, welches vorkonfiguriert ist, um Performer- 
und Comment-Tags auszulesen.

Möchten Sie die Konfiguration des Panels ändern, klicken 
Sie bitte mit der rechten Maustaste auf die Schaltfläche 
DET und wählen Splitter Settings. In der Panel List 
wählen Sie bitte den Eintrag DET aus und betätigen die 
Schaltfläche Configure.
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2.10.1.7 INF – Item Properties Panel The INF button shows an Item Properties panel which 
contains editable metadata information about the now 
playing or selected file as well as technical information 
about it.

If you want to change this configuration please do a right 
mouse click at the INF button and select Splitter Settings. 
Select INF in the PanelList and hit the Configure button.

Über die Schaltfläche INF gelangen Sie an ein Item 
Properties Panel, welches nicht nur alle Metadaten und 
technischen Informationen eines Titels anzeigt, sondern 
auch ermöglicht, die Metadaten gleich mit einem zweiten 
Klick ins jeweilige Value-Feld zu editieren.

Möchten Sie die Konfiguration des Panels ändern, klicken 
Sie bitte mit der rechten Maustaste auf die Schaltfläche 
INF und wählen Splitter Settings. In der Panel List wählen 
Sie bitte den Eintrag INF aus und betätigen die 
Schaltfläche Configure.

2.10.2 Panel Management To manage the Panels in the Panel switcher please go to 
MENU → File → Preferences → Columns UI → Layout tab 
and scroll down the explorer tree to the view illustrated on 
the left.

To remove an existing Panel do a right mouse click on it 
and select Remove panel.

To move an existing Panel do a right mouse click on it 
and select Move up, if you want to move it forward, or 
Move down, if you want to move it down in the list.

To add a Panel do a right mouse click on the Panel Stack 
Splitter - red framed in the illustration on the left – select 
Insert panel and select the desired Panel.

Now do a left mouse click on the Panel Stack Splitter and 
hit the Configure... button on the right hand of the Layout 

Um die Panel im Panel Umschalter zu verwalten, gehen 
Sie bitte über MENU → File → Preferences → Columns UI 
zur Registerkarte Layout und scrollen Sie in der 
Baumstruktur soweit hinunter, bis Sie die nebenstehend 
abgebildete Ansicht sehen.

Um ein vorhandenes Panel zu entfernen, klicken Sie bitte 
mit der rechten Maustaste darauf und wählen die Option 
Remove panel.

Um ein vorhandenes Panel zu verschieben, klicken Sie 
bitte mit der rechten Maustaste darauf und wählen Move 
up, wenn Sie das Panel in der Liste weiter nach vorn 
schieben wollen oder Move down, wenn Sie das Panel in 
der Liste nach hinten schieben wollen.

Um ein Panel hinzuzufügen, klicken Sie bitte mit der 
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page.

Select the new added Panel in the PanelList,  set the 
cursor in the Caption box, give it an up to three letters 
token and activate Forced Layout.

Close the Splitter Settings with a click on the OK button 
and hit the Apply button on the Layout page to finish your 
action.

rechten Maustaste auf den in der nebenstehenden Abb. 
rot umrandeten Panel Stack Splitter, wählen Sie Insert 
panel und wählen Sie das gewünschte Panel aus.

Klicken Sie anschließend mit der linken Maustaste auf 
den Panel Stack Splitter und betätigen Sie die 
Schaltfläche Configure... im rechten Bereich der 
Registerkarte.

Wählen Sie nun in der PanelList das neu hinzugefügte 
Panel, vergeben Sie bei Caption ein aussagekräftiges, 
maximal drei Zeichen langes Kürzel und aktivieren Sie 
Forced Layout.

Schließen Sie die Splitter Settings mit einem Klick auf die 
Schaltfläche OK und bestätigen Sie Ihre Änderungen auf 
der Registerkarte Layout mit einem Klick auf Apply.
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3. Colours and Fonts

3.1 Changing Colours

Foreground Background

Item 128-128-128 19-30-38

Selected Item 255-255-255 63-100-127

Inactive selected Item 192-192-192 44-70-89

Use custom active item frame       63-100-127

With some rare exceptions (see below) the whole colour 
scheme of the DarkOne configuration is done by 
Columns UI.

You can see the colours that are used by default in the 
illustration on the left. These may be useful, for instance 
when you add new Panels and you want to have them 
“fit” to the given colour scheme but they won't 
automatically adopt the colours given by Columns UI.

If you want to change the colour scheme you need to do 
this in different places, because – as said before – some 
of the used Panels won't automatically adopt the 
Columns UI colours completely.

I strongly recommend to note that the DarkOne 
configuration is made for dark background colours only, 
when you want to change the colour scheme!
If you'd use a light background colour some inalterable 
details of the configuration (image files) will become 
hardly visible.

Bis auf wenige Ausnahmen (siehe unten) wird das 
gesamte Farbschema der DarkOne Konfiguration über 
Columns UI bestimmt.

Der nebenstehenden Abbildung können Sie entnehmen, 
welche Farbwerte im Auslieferungszustand genutzt 
werden. Dies kann nützlich sein, z. B. wenn Sie neu 
Panel hinzufügen, die die genutzten Farbwerte nicht 
automatisch von Columns UI übernehmen, Sie diese 
aber dennoch an das bestehende Farbschema anpassen 
wollen.

Wenn Sie das Farbschema ändern möchten, müssen Sie 
das jedoch an verschiedenen Stellen in der Konfiguration 
vornehmen, da – wie bereits erwähnt – einige der 
genutzten Panel das Farbschema nicht automatisch oder 
vollständig übernehmen.

Ich empfehle aber dringend bei einer Änderung des 
Farbschemas darauf zu achten, eine möglichst dunkle 
Hintergrundfarbe zu wählen, da die DarkOne 
Konfiguration nur für diese ausgelegt ist!
Bei der Nutzung einer hellen Hintergrundfarbe würden 
einige unveränderliche Details der Konfiguration 
(eingefügte Bilddateien) nur noch schwer erkennbar sein.
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To change the colour scheme please do the following:

❶ Columns UI

MENU → File → Preferences → Columns UI → Colours 
and Fonts → Colours tab.
Select the entry Global from the upper dropdown list 
Element, select the entry Custom from the lower 
dropdown list Mode.
Now adjust the colours of an entry to your needs by 
pressing its Change... button.

❷ Panel Stack Splitter

Do a right mouse click as seen on the illustration on the 
left at one of this three buttons and select Splitter Settings 
→ Script → PerTrack tab.

Now adjust the script part, blue framed in the illustration 
on the left, to your needs (you need to do this in R-G-B-A) 
to change the background colour of the used Panel Stack 
Splitters.

❸ ELPlaylist

Please read chapter 2.8.1.3 how to change the 
ELPlaylists colour scheme (MAIN.COLOUR).
The columns font colours will be taken from Columns UI.

Gehen Sie zum ändern des Farbschemas wie folgt vor:

❶ Columns UI

Gehen Sie über MENU → File → Preferences → Columns 
UI → Colours and Fonts auf die Registerkarte Colours.
Wählen Sie nun aus der oberen Dropdown-Liste Element 
den Eintrag: Global, aus der unteren Dropdown-Liste 
Mode den Eintrag: Custom.
Passen Sie nun jeweils durch Betätigung der Schaltfläche 
Change... die vorgegebenen Werte Ihren Wünschen an.

❷ Panel Stack Splitter

Klicken Sie wie in der nebenstehenden Abbildung 
ersichtlich mit der rechten Maustaste auf eine der drei 
Schaltflächen und wählen Sie Splitter Settings → Script → 
Registerkarte PerTrack.
Passen Sie nun den in der nebenstehenden Abbildung 
blau umrandeten Script-Teil Ihren Wünschen an (die 
Eingabe ist in R-G-B-A vorzunehmen), um den 
Hintergrund der verbauten Panel Stack Splitter zu 
ändern.

❸ ELPlaylist

Lesen Sie bitte unter Kapitel 2.8.1.3 wie Sie das 
Farbschema (MAIN.COLOUR) der ELPlaylist ändern 
können.
Die Schriftfarben in den Spalten werden wie oben 
beschrieben von Columns UI übernommen.
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❹ Classical Display

The colours of the Tracknumber, Playing time, Bitrate and 
the Infoboxes may be also needed to be adjusted. Do a 
right mouse click on the Playing time area and select 
Properties, do a double left mouse click on the entries 
seen on the illustration on the left and adjust their values 
to your needs (R-G-B-A).

❺ Waveform seekbar Display

Do a right mouse click on the Waveform seekbar and 
select Configure.

It may be also necessary to adjust the colours of the 
Playing time area.

Do a right mouse click on the Playing time area and 
select Splitter Settings → Script.

Adjust on both tabs (PerTrack and Per Second) the 
numerical values in each $puts(t.col,...) function below 
the entry TIME-SECTION.

❻ Peakmeter

Please read chapter 2.4.3 how to change the colours of 
the Peakmeter.

❹ Klassisches Display

Die Farben der Titelnummer, Spielzeit, Bitrate und der 
Informationskästchen müssen u. U. angepasst werden. 
Klicken Sie dazu mit der rechten Maustaste auf den 
Bereich, der die Spielzeit anzeigt, wählen Sie Properties, 
doppelklicken Sie auf die nebenstehend abgebildeten 
Einträge und ändern Sie diese auf die gewünschten 
Werte (R-G-B-A).

❺ Waveform seekbar Display

Klicken Sie mit der rechten Maustaste auf die Waveform 
seekbar und wählen Sie Configure.

Außerdem kann es notwendig sein, die Farben der 
Spielzeit-/Restpielzeitanzeige anzupassen.

Klicken Sie hierzu mit der rechten Maustaste auf die 
Spielzeit und wählen Sie Splitter Settings → Script.

Ändern Sie auf beiden Registerkarten (PerTrack und Per 
Second) die Zahlenwerte in der jeweiligen $puts(t.col,...) 
Funktion unter dem Eintrag TIME-SECTION.

❻ Peakmeter

Lesen Sie bitte unter Kapitel 2.4.3 wie Sie die Farben des 
Peakmeters verändern können.
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3.2 Changing Fonts With some rare exceptions (see below) the used font 
style of the DarkOne configuration is done by Columns 
UI. The configurations default font style is Arial, 8pt Bold.

If you want to change the font style you need to do this in 
different places, because – as said before – some of the 
used Panels won't adopt the default font style 
automatically.

To change the default font style please do the following:

❶ Columns UI

MENU → File → Preferences → Columns UI → Colours 
and Fonts → Fonts tab.
Select the entry Common (list items) from the upper 
dropdown list Element, select the entry Custom from the 
lower dropdown list Mode.

Now adjust the font style to your needs by pressing the 
Change... button.

If you want to use an own font style for a special Panel 
search it in the dropdown list Element and fit it to your 
needs.

Bis auf wenige Ausnahmen (siehe unten) wird die 
genutzte Schriftart in der DarkOne Konfiguration über 
Columns UI bestimmt. Als Standardschriftart ist in der 
Konfiguration Arial, 8pt Bold vorgewählt.

Wenn Sie die Standardschriftart ändern möchten, 
müssen Sie das jedoch an verschiedenen Stellen in der 
Konfiguration vornehmen, da – wie bereits erwähnt – 
einige der genutzten Panel die Standardschriftart nicht 
automatisch übernehmen.

Gehen Sie zum ändern der Standardschriftart wie folgt 
vor:

❶ Columns UI

Gehen Sie über MENU → File → Preferences → Columns 
UI → Colours and Fonts auf die Registerkarte Fonts.
Wählen Sie nun aus der oberen Dropdown-Liste Element 
den Eintrag: Common (list items), aus der unteren 
Dropdown-Liste Mode den Eintrag: Custom.

Passen Sie nun durch Betätigung der Schaltfläche 
Change... die vorgegebenen Schriftart Ihren Wünschen 
an.

Wünschen Sie für einzelne Panel eine eigene Schriftart, 
dann rufen Sie bitte aus der Dropdown-Liste Element das 
jeweilige Element auf und passen Sie auch dieses Ihren 
Wünschen an.
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❷ ELPlaylist

The font style itself will be taken over from Columns UI, 
but font size and font option has to set manually...

Please read chapter Kapitel 2.8.1.3 
(COLUMNS.FONT.SIZE, COLUMNS.FONT.OPTION), 
how to adjust font size and font option.

❸ Display and Buttons

To edit the font style of the Buttons description and the 
display please do a right mouse click on the DO Global 
Script.js file from the folder 
...\foobar2000\themes\DarkOne\Others\WSH Scripts and 
select Edit.

Change the following red coloured script part to the 
desired Font style:
var btn_font = gdi.Font(„Arial Black", 7, 0)
var dsp_font = gdi.Font(„DarkOne“, 19, 0)

Means: („Font style“, Font size in Pixels (not Points!), 
Font option)

The following options are available for the Font option: 
0 – normal, 1 – bold, 2 – italic, 3 – bold/italic, 4 – 
underlined and 8 – strikeout.

❷ ELPlaylist

Die Schriftart wird wie oben beschrieben von Columns UI 
übernommen, blöderweise aber weder Schriftgröße und 
Schriftschnitt...

Lesen Sie bitte unter Kapitel 2.8.1.3 
(COLUMNS.FONT.SIZE, COLUMNS.FONT.OPTION), 
wie Sie diese Optionen einstellen können.

❸ Display- und Schaltflächenbeschriftung

Zum Bearbeiten der hierfür genutzten Schriftart, klicken 
Sie bitte mit der rechten Maustaste auf die Datei DO 
Global Script.js aus dem Ordner 
...\foobar2000\themes\DarkOne\Others\WSH Scripts und 
wählen Sie Bearbeiten.

Ändern Sie den nachfolgend rot dargestellten Script-Teil 
in die gewünschte Schriftart:
var btn_font = gdi.Font(„Arial Black", 7, 0)
var dsp_font = gdi.Font(„DarkOne“, 19, 0)

Die Bedeutung: („Schriftart“, Schriftgröße in Pixeln (nicht 
Punkten!), Schriftschnitt)

Für den Schriftschnitt stehen Ihnen folgende Optionen 
zur Verfügung: 
0 – Standard, 1 – Fett, 2 – Kursiv, 3 – Fett Kursiv, 4 – 
Unterstrichen und 8 – Durchgestrichen.

50



4. Troubleshooting

ERROR REASON POSSIBLE SOLUTION FEHLER URSACHE MÖGLICHE LÖSUNG

There are some parts of 
the configuration 
(images/panels) missing 
after foobar2000 start-up!

In very rare cases the 
Panel Stack Splitter 
seems to “forget” some 
details

Please restart foobar2000 Nach dem foobar2000 
Start werden einige 
Bestandteile der 
Konfiguration nicht 
angezeigt!

In seltenen Fällen scheint 
der Panel Stack Splitter 
einige Details zu 
„vergessen“

Starten Sie foobar2000 
erneut

foobar2000 crashes 
randomly

You are using outdated or 
buggy Plugins

Please search for updates 
or use Plugins provided 
with the DarkOne installer

foobar2000 stürzt immer 
wieder ab!

Sie nutzen veraltete oder 
fehlerhafte Plugins

Bitte suchen Sie nach 
Updates oder benutzen 
Sie die Plugins, die Sie 
mit DarkOne 
heruntergeladen haben

Remove unused and 
probably outdated Plugins 
from the Components 
page in MENU → File → 
Preferences via right-click 
on its name → Remove

Entfernen Sie ungenutzte 
und möglicherweise 
veraltete Drittanbieter-
Plugins unter MENU → 
File → Preferences → 
Components über 
Rechtsklick auf dessen 
Namen→ Remove
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ERROR REASON POSSIBLE SOLUTION FEHLER URSACHE MÖGLICHE LÖSUNG

foobar2000 crashes 
randomly

You are using outdated or 
buggy Plugins

Please inform me about 
crashes when they are 
caused by Components 
provided with the 
DarkOne download so I 
can remove them 
immediately!

foobar2000 stürzt immer 
wieder ab!

Sie nutzen veraltete oder 
fehlerhafte Plugins

Informieren Sie mich bitte, 
falls eines der 
mitgelieferten 
Components Abstürze 
verursacht, damit ich 
dieses nach Möglichkeit 
umgehend mit einem 
stabileren Plugin 
austauschen kann!

The Rating Panel and the 
rating display in the 
Playlist are displaying 
always all stars/the whole 
bar in Playcounter mode!

The play count limit is set 
much too low.

Choose a higher limit for 
the play counts as 
described in chapters 
2.2.1 and 2.8.1.3

Wenn ich die 
Wiedergabeliste und das 
Rating Panel darauf 
einstelle, mir die 
Abspielvorgänge 
anzuzeigen, leuchten 
ständig alle Sterne auf!

Sie haben das Limit für 
die Abspielvorgänge zu 
niedrig angesetzt

Wählen Sie ein höheres 
Limit für die 
Abspielvorgänge, wie in 
Kapitel 2.2.1 und 2.8.1.3 
beschrieben

The ELPlaylists Popup 
window doesn't shows the 
correct image!

You have chosen a wrong 
option (front, back, disc, 
icon, artist) for the 
foobar2000 artreader

Change the POPUP.ART 
in the ELPlaylists field 
definitions as described in 
chapter 2.8.1.3

In der ELPlaylist 
bekomme ich im Popup-
Fenster nicht das korrekte 
Bild angezeigt!

Sie haben die falsche 
Option (front, back, disc, 
icon, artist) des 
foobar2000 artreaders 
gewählt

Ändern Sie POPUP.ART 
in den ELPlaylist 
Einstellungen, wie unter 
Kapitel 2.8.1.3 
beschrieben
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ERROR REASON POSSIBLE SOLUTION FEHLER URSACHE MÖGLICHE LÖSUNG

There are no covers 
displayed in the 
ELPlaylist!

The ELPlaylist is using 
the foobar2000 artreader 
but your albums don't 
have embedded album art 
nor album art that the 
artreader can recognise

Change the name of your 
covers to folder.*, cover.* 
or front.*

Es werden keine Bilder in 
der ELPlaylist angezeigt!

Die ELPlaylist nutzt den 
foobar2000 Artreader, 
aber Ihre Alben haben 
weder Cover in den Tags, 
noch kann der Artreader 
Ihre Bilder erkennen

Ändern Sie die Namen 
Ihrer Bilder auf folder.*, 
cover.* oder front.*

Add a new suitable 
naming scheme to 
Preferences → Display

Fügen Sie unter 
Preferences → Display ein 
neues, passendes 
Namensschema hinzu

The auto-cycling doesn't 
work when “Faded 
Transition” is chosen!

You are using Windows 
XP/Vista and/or a 
Graphics card that isn't 
fully compatible with this 
functionality

Disable “Faded 
Transition”

Im Cover Panel 
funktioniert der 
automatische Bildwechsel 
nicht, wenn die sanfte 
Aus-/Einblendung 
aktiviert ist!

Sie nutzen Windows 
XP/Vista und/oder eine 
nicht mit der sanften 
Aus-/Einblendung 
kompatiblen Grafikkarte

Schalten Sie die sanfte 
Aus-/Einblendung beim 
automatischen 
Bildwechsel ab!

I made some changes in 
the ELPlaylist but want to 
return to the default 
settings!

Oops... Right-click in the 
ELPlaylist, choose 
Settings → Import and 
import the file 
ELPlaylist.elp from the 
folder 
...\foobar2000\themes
DarkOne\Others\Settings

Ich habe einige 
Änderungen an der 
ELPlaylist vorgenommen, 
möchte jedoch wieder in 
den Ursprungszustand 
zurückkehren!

Na sowas... Rechtsklicken Sie auf die 
ELPlaylist, wählen Sie 
Settings → Import und 
importieren Sie die Datei 
ELPlaylist.elp aus dem 
Ordner: 
...\foobar2000\themes\
DarkOne\Others\Settings
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ERROR REASON POSSIBLE SOLUTION FEHLER URSACHE MÖGLICHE LÖSUNG

I changed a script part of 
a WSH Panel and it 
doesn't work anymore!

Seems you made a 
mistake ;)

Go to the affected WSH 
Panel, do a right mouse 
click on it and select 
Configure.

Import the associated 
script with the Tools → 
Import button from the 
folder 
...\foobar2000\themes\
DarkOne\Others\WSH 
Scripts

Ich habe das Script eines 
WSH Panels geändert 
und nun arbeitet es nicht 
mehr!

Scheint so, als hätten Sie 
einen Fehler gemacht ;)

Gehen Sie zu dem 
betroffenen WSH Panel, 
klicken Sie mit der 
rechten Maustaste darauf 
und wählen Sie 
Configure.
Importieren Sie mit der 
Schaltfläche Tools → 
Import das betreffende 
Script aus dem Ordner: 
...\foobar2000\themes\
DarkOne\Others\WSH 
Scripts

I made some changes in 
the configuration but want 
to return to the default 
settings!

Shit happens :) Reimport the file DarkOne 
v3.0.fcl 

Ich habe die 
Konfiguration verändert, 
möchte dies jedoch 
rückgängig machen!

Soll vorkommen :) Importieren Sie die Datei 
DarkOne v3.0.fcl einfach 
erneut

foobar2000 freezes on 
track change when 
listening to last.fm 
(optional) for a few 
seconds

Unknown reason Unknown :( Beim hören über last.fm 
(optional) friert 
foobar2000 beim 
Liedwechsel jedes mal für 
mehrere Sekunden ein!

Ursache unbekannt Unbekannt :(
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ERROR REASON POSSIBLE SOLUTION FEHLER URSACHE MÖGLICHE LÖSUNG

Foobar2000 doesn't 
responds after doing a 
double left mouse click on 
a file in the Playlist!

Unknown reason You may need to restart 
your PC to get it back 
working...

Foobar2000 reagiert nicht 
mehr nach dem 
Doppelklick auf einen 
Titel in der Playlist!

Unbekannte Ursache Sie werden 
möglicherweise Ihren PC 
neu starten müssen, um 
foobar2000 wiedre zum 
Laufen zu bringen...

foobar2000 often freezes 
during playback!

You use outdated or 
buggy Plugins

Please search for updates 
or use Plugins provided 
with the DarkOne v3.0 
package

Während des Abspielens 
eines Liedes friert 
foobar2000 immer wieder 
kurz ein!

Sie nutzen veraltete oder 
fehlerhafte Plugins

Bitte suchen Sie nach 
Updates oder benutzen 
Sie die Plugins, die Sie 
mit DarkOne v3.0 
heruntergeladen haben

The Biography view panel 
is set up too power 
consumptive for your 
system

Do a right mouse click on 
the Biography view panel 
and deactivate Options → 
Auto Cycle Image

Das Biography view panel 
ist für Ihr System zu 
leistungshungrig 
eingestellt

Klicken Sie mit der 
rechten Maustaste in das 
Biography view panel und 
deaktivieren Sie Options 
→ Auto Cycle Image

Do a right mouse click on 
the Biography view panel, 
choose Panel 
Preference... and select 
Font Renderer GDI+

Gehen Sie mit einem 
Klick der rechten 
Maustaste in die Panel 
Preference... und wählen 
Sie Font Renderer GDI+
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ERROR REASON POSSIBLE SOLUTION FEHLER URSACHE MÖGLICHE LÖSUNG

CPU-consumption is 
much higher with 
DarkOne v3.0!

The visualisation is set to 
its highest capacity

Change its Settings as 
described in chapter 2.6

Die CPU-Auslastung ist 
mit DarkOne v3.0 deutlich 
erhöht!

Das Visualisierung ist auf 
höchste Leistung gesetzt

Ändern Sie die 
Einstellungen des Panels, 
siehe Kapitel 2.6.

RAM usage raises higher 
and higher during 
playback!

The Biography view panel 
seems to save all 
informations and images 
loaded during playback in 
your RAM without 
disposing them

Deactivate Auto Cycle 
Image

Während des Abspielens 
mit foobar2000 wächst 
dessen 
Speicherverbrauch ins 
Unermessliche!

Das Biography view panel 
speichert alle Daten und 
Bilder offenbar für 
schnelleren Zugriff im 
RAM Ihres Systems, ohne 
diese Informationen 
wieder zu entsorgen

Deaktivieren Sie Auto 
Cycle Image

Do a right mouse click on 
the Biography view panel, 
choose Panel 
Preference... and 
deactivate Show Text and 
Show Image

Gehen Sie mit einem 
Klick der rechten 
Maustaste in die Panel 
Preference... und 
deaktivieren Sie Show 
Text und Show Image
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